Here are the system requirements you need in order to use Dynamic Content for Elementor. If you are not sure whether or not your server supports this, contact your host.

  • WordPress 5.2 or greater;

  • PHP 7 or greater or greater. From the end of April 2021 PHP 5.6 is not more supported;

  • MySQL 5.6 or Greater;

  • WP Memory Limit of 256 MB or greater if you need all features activated else you can disable some features;

  • Elementor free version 2.9.11 or greater and its minimum requirements.




Did this answer your question?